We Are moving
Resolved
Jul 26, 2026 at 5:57pm UTC
Maintenance ended
Affected services
Updated
Jul 26, 2026 at 5:57pm UTC
Maintencance ended
All our services are back up! Thanks you for your patience.
Affected services
Updated
Jul 20, 2026 at 7:47pm UTC
The ReCreated Server is back up. You can play again.
Affected services
Created
Jul 18, 2026 at 5:00am UTC
We are currently switching server providers. During this time our Minecraft Network will be unavailable. You can continue playing in just a few days.
Your SurvivalProductions Team
Affected services